VisTrails Home

Building CDAT on Mac

From VisTrailsWiki

(Difference between revisions)
Jump to: navigation, search
Line 1: Line 1:
 +
'''These instructions were tested only on mac intel, with python versions 2.4.3 and 2.5.1'''
 +
* Requirements
* Requirements
** You will need X11 to run CDAT. If you don't have it, install it from your Mac OS X Install Disc  
** You will need X11 to run CDAT. If you don't have it, install it from your Mac OS X Install Disc  

Revision as of 22:54, 28 June 2007

These instructions were tested only on mac intel, with python versions 2.4.3 and 2.5.1

  • Requirements
    • You will need X11 to run CDAT. If you don't have it, install it from your Mac OS X Install Disc
  • Download cdat form the source code repository
  svn checkout http://www-pcmdi.llnl.gov/svn/repository/cdat/trunk cdat 
  • Download this patch (building NetCDF without Fortran support) or if you have fortran compiler installed, download this other patch and uncompress to the cdat folder.
  • Perform the following commands:
 $ unset PYTHONPATH
 $ cd cdat/exsrc
 $ sudo ./install_script /Library/Frameworks/Python.framework/Versions/2.4
 
 $ sudo python install.py /Library/Frameworks/Python.framework/Versions/2.4
  • Before running vistrails, reset PYTHONPATH variable:
 $ export PYTHONPATH=<path/to/vtk_build>/Wrapping/Python:<path/to/vtk_build>/bin:.

When running vistrails with cdat package, you'll have to run vistrails from an X11 terminal.

Personal tools