VisTrails Home

InstallingVisTrailsOnUbuntu

From VisTrailsWiki

(Difference between revisions)
Jump to: navigation, search
(New page: When installing VisTrails on a Debian-based linux distribution (any variant using the apt package management system) the following commands must be issued as the root user or preceeded by ...)
(Latest installation procedure on ubuntu)
 
(13 intermediate revisions not shown)
Line 1: Line 1:
-
When installing VisTrails on a Debian-based linux distribution (any variant using the apt package management system) the following commands must be issued as the root user or preceeded by sudo
+
VisTrails now interfaces with apt directly via a Python API. This allows dynamic installation of necessary packages. As a result, you don't need to install any packages for the basic VisTrails install either. Just download the source and execute it with
-
Install Graphviz:
+
$ python vistrails.py
-
* apt-get install graphviz
+
-
Install Python:
+
and VisTrails should detect all necessary software and, if necessary, ask for your permission to install it.
-
* apt-get install python
+
-
 
+
-
Install Python Extensions:
+
-
* apt-get install python-xml
+
-
* apt-get install python-soappy
+
-
 
+
-
Install Qt 4.2.0 or above:
+
-
* You can get the open source version for all platforms [http://www.trolltech.com/download/opensource.html here]
+
-
* After downloading, you need to build the Qt library:
+
-
  * Run '''configure''' then '''make'''
+
-
 
+
-
Install PyQt4:
+
-
* Note: The Python bindings for QT4 provided by the apt-get installation work only for QT 4.1
+
-
* Download sip 4.5.2 [http://www.riverbankcomputing.co.uk/sip/download.php here]
+
-
  * sudo python configure.py
+
-
  * sudo make; make install
+
-
* Download PyQt4.1.1 [http://www.riverbankcomputing.co.uk/pyqt/download.php here]
+
-
  * sudo python configure.py
+
-
  * sudo make; make install
+
-
 
+
-
Install MySQLdb (Python library allowing MySQL databases access):
+
-
* apt-get install python-mysqldb
+
-
 
+
-
Install SciPy and NumPy
+
-
* sudo apt-get install python-scipy (python-numpy is a dependency that is installed automatically by apt)
+

Current revision as of 13:22, 16 May 2008

VisTrails now interfaces with apt directly via a Python API. This allows dynamic installation of necessary packages. As a result, you don't need to install any packages for the basic VisTrails install either. Just download the source and execute it with

$ python vistrails.py

and VisTrails should detect all necessary software and, if necessary, ask for your permission to install it.

Personal tools