VisTrails Home

Improve error handling/reporting

From VisTrailsWiki

(Difference between revisions)
Jump to: navigation, search
Line 22: Line 22:
== core/bundles/linux_ubuntu_install.py ==
== core/bundles/linux_ubuntu_install.py ==
* Print statements are used for installing deb packages. I am not sure if I can remove any.
* Print statements are used for installing deb packages. I am not sure if I can remove any.
-
 
== core/data_structures/point.py ==
== core/data_structures/point.py ==
* Contains print statements but should this low-level library have a dependency on core/debug?
* Contains print statements but should this low-level library have a dependency on core/debug?
 +
== gui/application_server.py ==
 +
* Contains lots of debug print statements that might still be used?

Revision as of 12:21, 15 November 2010

  • Splash screen now shows package initialization
  • Classifying log levels
    • debug 10 (cannot be accessed by setting loglevel)
    • log(info) 20
    • warning 30
    • critical 50
  • ~800 print statements in VisTrails + 200 commented ones

Contents

Conversion issues

core/upgradeworkflow.py

  • print "module %s already handled. skipping" % module_id - log or warning?
  • debug.critical('Package cannot handle upgrade request. VisTrails will attempt automatic upgrade.') - Should it be critical?

core/analogy/__init__.py

  • if _debug: print 'version_a:', version_a (and a lot of similar) - Is it currently being debugged? remove?

core/analogy/eigen.py

  • print m_i: remove?

core/bundles/installbundle.py

  • A lot of print statements are used for installing deb/rpm packages. I am not sure if I can remove any.

core/bundles/linux_ubuntu_install.py

  • Print statements are used for installing deb packages. I am not sure if I can remove any.

core/data_structures/point.py

  • Contains print statements but should this low-level library have a dependency on core/debug?

gui/application_server.py

  • Contains lots of debug print statements that might still be used?
Personal tools